Page 1 of 1

Why does app work with 4G but not WiFi??

PostPosted: Sun Feb 03, 2013 10:27 pm
by aviator24
I have a Tenvis IP wifi camera and it works fine. I am able to use my laptop to view and control feed and recordings. I downloaded the App and paid for it for my Droid Razr Maxx on Verizon and at first it worked just fine. NOW, however, I must shut off my Wifi and goto 4G in order to see my camera feed. Every time I try to view the camera feed using Wifi it will not work?? I ran a Wifi speed test and my speeds are good, 21 Mps download and 4 Mps Upload. I do not understand why I can watch my camera on my cellphone only when my WIFI is turned off?? I am able to use my laptop to watch my camera with no trouble, just when I use my cellpone. Any Ideas?? Wifi is free, 4G is limited...

Re: Why does app work with 4G but not WiFi??

PostPosted: Sun Mar 03, 2013 7:41 pm
by N4Spd
Most routers will recognize that a WAN IP (or a hostname) is actually your own and then redirect traffic back into the internal network.
This is called NAT LOOPBACK, and allows you to enter one address for access both from inside and outside your network.

1. reboot router (that function might have hung)
2. check router settings to ensure NAT LOOPBACK is enabled

3. if all fails, get new router, or create 2 sets of cameras and use the grouping function to switch between them.

Thanks,
Rob

Re: Why does app work with 4G but not WiFi??

PostPosted: Mon Feb 08, 2016 3:54 pm
by celler
I am having a similar problem with cameras not being available when I am on the same wi-fi network as the cameras. I checked the nat loopback issue, but dd-wrt says its working properly if I can ping my external ip address which I can. I also tried adding a new camera to IP Cam Viewer using the internal ip address of the camera to see if that would work and cannot access it internally. It almost feels like ap isolation on the internal side, but I have not enabled anything like that and internal network shares are working fine. Everything works fine on external network. Any ideas? Thanks.

Re: Why does app work with 4G but not WiFi??

PostPosted: Fri May 06, 2016 8:20 am
by viperiii
OP what firewall router do you have? Know its running DD-wrt

but is the url you're using for your CAMs?

IP / URL?

DD-WRT can also do some DNS - depending what your using for dns on your LAN.

can make cameras.home.com resolve internal IP when on LAN and WAN just just edit via normal cnames.

if using IP address - then something is afoot with dd-wrt config. - from phone can you see / open dd-wrt config? - ap isolation might be on..

What version of DD-WRT are you running and what hardware?

Re: Why does app work with 4G but not WiFi??

PostPosted: Thu Jun 02, 2016 1:48 pm
by N4Spd
Most routers will recognize that a WAN IP (or a hostname) is actually your own and then redirect traffic back into the internal network.
This is called NAT LOOPBACK, and allows you to enter one address for access both from inside and outside your network.

1. reboot router (that function might have hung)
2. check router settings to ensure NAT LOOPBACK is enabled (also try turning off NAT acceleration)

3. if all fails, get new router, or create 2 sets of cameras and use the grouping function to switch between them.
http://hit-mob.com/ip-cam-viewer-android/help/#23

I recommend routers with DD-WRT. Some Buffalo routers comes with DD-WRT installed (see below):
http://astore.amazon.com/andrapps-20

ps. here's a list of routers supporting nat loopback
http://opensimulator.org/wiki/NAT_Loopb ... odem_Table

Re: Why does app work with 4G but not WiFi??

PostPosted: Mon May 14, 2018 2:16 pm
by Chef
aviator24 wrote:I have a Tenvis IP wifi camera and it works fine. I am able to use my laptop to view and control feed and recordings. I downloaded the App and paid for it for my Droid Razr Maxx on Verizon and at first it worked just fine. NOW, however, I must shut off my Wifi and goto 4G in order to see my videos gay feed. Every time I try to view the camera feed using Wifi it will not work?? I ran a Wifi speed test and my speeds are good, 21 Mps download and 4 Mps Upload. I do not understand why I can watch my camera on my cellphone only when my WIFI is turned off?? I am able to use my laptop to watch my camera with no trouble, just when I use my cellpone. Any Ideas?? Wifi is free, 4G is limited...



I also happen something similar, for now I use only the 4G

Re: Why does app work with 4G but not WiFi??

PostPosted: Wed May 30, 2018 8:11 am
by mavedele
aviator24 wrote:I have a Tenvis IP wifi camera and it works fine. I am able to use my laptop to view and control feed and recordings. I downloaded the App and paid for it for my Droid Razr Maxx on Verizon and at first it worked just fine. NOW, however, I must shut off my Wifi and goto 4G in order to see my camera feed. Every time I try to view the camera feed using Wifi it will not work?? I ran a Wifi speed test and my speeds are good, 21 Mps download and 4 Mps Upload. I do not understand why I can watch my camera on my cellphone only when my WIFI is turned off?? I am able to use my laptop to watch my camera with no trouble, just when I use my cellpone. Any Ideas?? Wifi is free, 4G is limited...


Hi
I have some very similar problem. My cameras are set on local network and remotely accessed via VPN (I have fixed IPs). IPcamviewer works fine with my iphone in 4G but more complicated when using a wifi network, at home or in an other place : sometime it works, sometime not, I need to connect/deconnect the VPN several times or closing/reopening ipcamviewer. Looks like something remains in the memory ...
it is NOT a problem with portforwarding (I don't need it ).
My router is actually an internet box (Freebox). May it be linked to the provider ? Any other idea ?
Thanks