Page 1 of 1

SSL Handshake Error

PostPosted: Mon Jan 15, 2018 3:15 pm
by bithead
I have 3 Foscam FI9821 V2 cams and 2 Amcrest IPM2-841s. I am running IP Cam Viewer Basic on one device and IP Cam Viewer Lite on another. Both devices are running Android 7.0 with the 12/1/17 patches. I used to be able to access all 5 cams via SSL over the internet with appropriate port forwards in my firewall. I don't access them remotely on a regular basis, so I can't say exactly when things broke, but as of some time fairly recently, I can no longer access the Foscam cams. Access to the Amcrest cams still works.

When editing the Foscams and I press the Test button, a message comes up stating:
SSL Handshake Error (not supported). For Android 5.1+, check SSL/TLS options in App Settings.

First, I don't understand why if SSL Handshakes are not supported, why things still work with Amcrest cams - the Amcrest and Foscam cams are configured identically and I haven't changed their configs at all since all of them worked.

Second, as for the SSL/TLS app settings, I have tried Old+New Ciphers/Protocols, Old Ciphers/Protocols, and New Ciphers/Protocols, and they all give the same results - Amcrest cameras work, Foscam cameras do not. Perhaps the error message itself is erroneous?

Finally, all cameras work when the Android devices are connected to my local wi-fi network.

I'm hoping for some insights as to why the Foscam cams have stopped working via the internet. Thanks!

~bh

Re: SSL Handshake Error

PostPosted: Mon Jan 29, 2018 8:27 pm
by admin
some cameras use old ssl and newer iOS/Android devices disabled some older ciphers/ssl etc...

best to just make all camera ports visible through stunnel.
that way, no cameras are accessible directly from outside, only through ssl via stunnel.