IP Cam Viewer     My Amazon IP Cameras    

Foscam FI9821/9831/9805/9826/9828 audio / ptz / video issues

Support for my free Android Applications.

Foscam FI9821/9831/9805/9826/9828 audio / ptz / video issues

Postby N4Spd » Thu Jan 10, 2013 2:44 pm

See end of this post for V2 firmware used in newer 9805/9821/9831/9826/9828 models (which do not use a separate media port).

===
1. This section applies to older FI9821 cameras that use a separate MEDIA port.

---
1a. getting email from people that audio or ptz is not working, or that video is slow.

the issue is that audio (and streaming video) is available on the Media port and many people are forgetting to port forward it. this can also cause ptz to fail.

the app's driver will fallback to a slow method to access the camera if the Media port is not available and that is the reason audio is not working.

so, first, make sure Active-X IE browser interface is working from outside your house, then try my app (the active-x interface uses the Media port).

you still put the web port into my app (the driver will ask the camera for it's media port and try to access it).

Finally, your audio will fail or stutter if resolution or fps is too high. Lower resolution and set fps=3 for selected stream.

For example, put 4 in Ch.# field to select stream 4 which is better (vga, fps=3, key intr.=10).

---
1b. video is delayed or slow.

if the camera fps is set too high, then the buffer fills up with stale frames and thus the delay footage.

Lower resolution and set fps=3 for selected stream.

For example, put 4 in Ch.# field to select stream 4 which is better (vga, fps=3, key intr.=10).


===
2. This section applies to newer F9805 and FI9821 V2 cameras that do NOT use a separate MEDIA port.

Leave the "Ch.#" field blank and the driver will default to mjpeg initially but switch to h.264 stream 4 if audio is enabled.

To force h.264 all the time, enter the stream number in the Ch.# field.

NEW: for iOS v2.1.9+ and Android 5.2.6+: If you'd like to use mjpeg initially but switch to a specific h.264 stream when audio is enabled, then enter stream# in Ch.# field but select "prefer quality over speed" setting in More Options.

---
2a. getting email from people that audio is slow.

Your audio will fail or stutter if resolution or fps is too high. Lower resolution and set fps=3 for the selected stream.

For example: (vga, fps=3, key intr.=10)

---
2b. video is delayed or slow.

if the camera resolution or fps is set too high, then the buffer fills up with stale frames and thus the delay footage.

Lower resolution and set fps=3 for the selected stream.

For example: (vga, fps=3, key intr.=10)

---
2c. Ch.# field mapping to camera streams (v5.5.6+)

Ch.1 - main stream, stream type 0
Ch.2 - sub stream, stream type 0
Ch.3 - main stream, stream type 2
Ch.4 - main stream, stream type 3 (best for mobile)
Ch.5 - sub stream, stream type 1
Ch.6 - main stream, stream type unchanged
Ch.7 - sub stream, stream type unchanged
*blank*, as in emtpy Ch.# field - will try mjpeg feed first, else fallback to Ch.4


===
2. This section applies to newer FI9831 cameras that do NOT use a separate MEDIA port.

Leave the "Ch.#" field blank and the driver will default to mjpeg initially but switch to h.264 stream 2 if audio is enabled.

To force h.264 all the time, enter the stream number in the Ch.# field.

NEW: for iOS v2.1.9+ and Android 5.2.6+: If you'd like to use mjpeg initially but switch to a specific h.264 stream when audio is enabled, then enter stream# in Ch.# field but select "prefer quality over speed" setting in More Options.

---
2a. getting email from people that audio is slow.

Your audio will fail or stutter if resolution or fps is too high. Lower resolution and set fps=3 for the selected stream.

For example: (vga, fps=3, key intr.=10).

---
2b. video is delayed or slow.

if the camera fps is set too high, then the buffer fills up with stale frames and thus the delay footage.

Lower resolution and set fps=3 for selected the stream.

For example: (vga, fps=3, key intr.=10).

===
N4Spd
 
Posts: 1369
Joined: Sun Feb 08, 2009 3:25 pm

Re: Foscam FI9821 audio and ptz

Postby Mort » Wed Feb 06, 2013 8:00 pm

Rob,

I've been able to effectively use the activeX PTZ controls with the 9821, but still have issues from my iOS device via WIFI. Presets work, but not the other PTZ controls.

I'm sticking to wifi for now, so I don't think opening up ports is required. Any other thoughts?

Thanks!
Mort
 
Posts: 6
Joined: Wed Jul 20, 2011 3:27 pm

Re: Foscam FI9821 audio / ptz / video issues

Postby IsaacB » Sat May 04, 2013 8:04 pm

PT & Presets are failing when connected (with IPC Lite, upgraded via in-app purchase on iPhone 3GS, iOS 6.1.3) to the FI9821W (firmware 1.1.1.12) via HTTPS with an Operator level ID. I'm finding this whether I'm connecting remotely (https://######.myfoscam.org:443 or locally https://192.168.1.6:443), via wifi or 3G connection. When logged in with an Admin level ID, PT works, but Presets fail.

Thanks.
Last edited by IsaacB on Sun May 05, 2013 6:09 am, edited 1 time in total.
IsaacB
 
Posts: 3
Joined: Sat May 04, 2013 4:35 am

Re: Foscam FI9821 audio / ptz / video issues

Postby IsaacB » Sat May 04, 2013 8:23 pm

Also note: These functions work fine when using the Foscam browser plugin.

Thanks.
IsaacB
 
Posts: 3
Joined: Sat May 04, 2013 4:35 am

Re: Foscam FI9821/9831/9805/9826/9828 audio / ptz / video issues

Postby floggingmolly » Tue Oct 21, 2014 6:49 pm

So frustrating...

I just replaced a Foscam camera that broke (power connector) with an FI9821P model. I should have checked here or the app first to see what level of support was available. Doh.

There is no FI9821P specific driver in the app, and the FI9821 driver doesn't seem to make audio work at all. The FI9821 V2 driver DOES work a little bit better, but audio is choppy (I get about .5 seconds of audio every second , then it cuts out). I've tried channel 4, I've tried making the resolution the smallest the camera can do, bitrate low, etc, etc. Then I noticed tonight the PT controls don't do anything.

Am I out of luck here? What do I need to do to get the FI9821P supported? Buy one for the dev? Desperate here...
floggingmolly
 
Posts: 1
Joined: Tue Oct 21, 2014 8:57 am

Re: Foscam FI9821/9831/9805/9826/9828 audio / ptz / video issues

Postby admin » Fri Dec 26, 2014 1:48 pm

use the "Foscam FI9821 V2" with the camera's http port (not https because their https can intermittently fail causing some commands to be dropped).
if you want https, use stunnel to protect all your cameras instead.
User avatar
admin
Site Admin
 
Posts: 172
Joined: Sun Feb 08, 2009 11:19 am

Re: Foscam FI9821/9831/9805/9826/9828 audio / ptz / video issues

Postby ostbey » Sun Jan 24, 2016 12:44 am

I have two Foscam cameras FI9826W and I'm using the paid ("pro") version of IPCV both on a Samsung Galaxy Note 2 Android smartphone and an iPhone 6 plus with iOS 9.2.1 (13D15).

On my LAN at home both phones and both cameras work pretty well in IPCV using HTTP.
But via Internet, no matter whether via WiFi or mobile provider (Vodafone.nl) PTZ doesn't work via HTTPS, only via HTTP.

On my Android phone I have to try about 20 times to do a pan, each rewarded by the error message "Pan/Tilt failed.".
When finally after many attempts the camera deigns to react, it goes all the way to the left or right end, no matter how short I tipped on the left or right arrow.

On my iPhone I can't even get a connection via HTTPS.

For obvious security concerns, this is of course unacceptable.
And I'm not even talking about the invalid provider certificates.

What is the cause of these problems, and what can I do to solve them?
Thank you!
ostbey
 
Posts: 1
Joined: Thu Jan 21, 2016 2:31 pm

Re: Foscam FI9821/9831/9805/9826/9828 audio / ptz / video issues

Postby admin » Mon Feb 15, 2016 9:15 pm

tbat camera's built-in ssl has issues. sometimes it fails on android. new iOS versions will refuse it. besides, the video feed does not even use https so worthless.

not app issue. use stunnel instead.

note that I've answered this multiple times on this same thread. read people.
User avatar
admin
Site Admin
 
Posts: 172
Joined: Sun Feb 08, 2009 11:19 am


Return to Support

Who is online

Users browsing this forum: No registered users and 5 guests